32 lines
891 B
Nix
32 lines
891 B
Nix
# Edit this configuration file to define what should be installed on
|
|
# your system. Help is available in the configuration.nix(5) man page, on
|
|
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
|
|
{ config
|
|
, lib
|
|
, pkgs
|
|
, ...
|
|
}: {
|
|
imports = [ ];
|
|
|
|
boot.loader.systemd-boot.enable = true;
|
|
boot.loader.efi.canTouchEfiVariables = true;
|
|
boot.initrd.availableKernelModules = [ "xhci_pci" "virtio_pci" "virtio_scsi" "usbhid" "sr_mod" ];
|
|
boot.initrd.kernelModules = [ ];
|
|
boot.kernelModules = [ ];
|
|
boot.extraModulePackages = [ ];
|
|
|
|
mySystem = {
|
|
services.openssh.enable = true;
|
|
security.wheelNeedsSudoPassword = false;
|
|
|
|
# Restic backups disabled.
|
|
system.resticBackup =
|
|
{
|
|
local.enable = false;
|
|
remote.enable = false;
|
|
};
|
|
};
|
|
|
|
networking.useDHCP = lib.mkDefault true;
|
|
nixpkgs.hostPlatform = lib.mkDefault "aarch64-linux";
|
|
}
|