theshire/shell.nix
Joseph Hanson d9ff973a55
moving to the shire
Expanding from 1 node to 6 + 2 VMs with GPUs
2024-09-04 13:35:14 -05:00

23 lines
433 B
Nix

# Shell for bootstrapping flake-enabled nix and home-manager
{pkgs ? import <nixpkgs> {}}:
pkgs.mkShell {
# Enable experimental features without having to specify the argument
NIX_CONFIG = "experimental-features = nix-command flakes";
nativeBuildInputs = with pkgs; [
fluxcd
git
gitleaks
go-task
helmfile
k9s
krew
kubectl
kubevirt
kubernetes-helm
pre-commit
sops
age
];
}