forgejo-ci-runners/profiles/hw-shadowfax.nix
2024-09-13 18:27:50 -05:00

17 lines
420 B
Nix

{ ... }:
{
imports = [
./host-qemu.nix
];
config = {
boot = {
initrd.availableKernelModules = [ "ahci" "virtio_pci" "virtio_scsi" "sr_mod" "virtio_blk" ];
initrd.kernelModules = [ "virtio_gpu" ];
extraModulePackages = [ ];
loader.systemd-boot.enable = true;
# since it's a vm, we can do this on every update safely
loader.efi.canTouchEfiVariables = true;
};
};
}